Skip to main content
← All vulnerabilities
CVE-2026-41293GHSA-R29C-68GH-XP6XBIT-TOMCAT-2026-41293

Apache Tomcat: HTTP/2 request headers not validated

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 9.0.118, 10.1.55, 11.0.22
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Improper Input Validation vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 10.0.0-M1 through 10.0.27. Older, end of support versions may also be affected. Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.21; From 10.1.0-M1 · through 10.1.54; From 9.0.0.M1 · through 9.0.117; From 10.0.0-M1 · through 10.0.27; From 8.5.0 · through 8.5.100

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 8.5.0 · fixed in 9.0.118

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.0-M1 · fixed in 10.1.55

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.0-M1 · fixed in 11.0.22

  • org.apache.tomcat:tomcatMaven

    From 8.5.0 · fixed in 9.0.118

  • org.apache.tomcat:tomcatMaven

    From 10.1.0-M1 · fixed in 10.1.55

  • org.apache.tomcat:tomcatMaven

    From 11.0.0-M1 · fixed in 11.0.22

  • org.apache.tomcat:tomcat-coyoteMaven

    From 8.5.0 · fixed in 9.0.118

  • org.apache.tomcat:tomcat-coyoteMaven

    From 10.1.0-M1 · fixed in 10.1.55

  • org.apache.tomcat:tomcat-coyoteMaven

    From 11.0.0-M1 · fixed in 11.0.22

References 2

lists.apache.org

GitHub · xiaoqiMikko/tomcat-check