Skip to main content
← All vulnerabilities
CVE-2026-40985GHSA-9GGW-87M9-9GFC

Data Binding Vulnerability in Spring Web Flow with Unified EL Parser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.0.1, 3.0.1.1, 2.5.2, 4.0.1, 3.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. Affected versions: Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Spring Spring Web Flow

    From 4.0.0 · fixed in 4.0.0.1; From 3.0.0 · fixed in 3.0.1.1; From 2.5.0 · fixed in 2.5.2

  • org.springframework.webflow:spring-webflowMaven

    From 4.0.0 · fixed in 4.0.1

  • org.springframework.webflow:spring-webflowMaven

    From 3.0.0 · fixed in 3.0.2

  • org.springframework.webflow:spring-webflowMaven

    through 2.5.1

References 1

spring.io