Skip to main content
← All vulnerabilities
CVE-2026-40976GHSA-8V8J-3HXP-93WR

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.6
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Spring Spring Boot

    From 4.0.0 · fixed in 4.0.6

  • org.springframework.boot:spring-bootMaven

    From 4.0.0 · fixed in 4.0.6

References 2

spring.io

GitHub · madebyrokit/CVE-2026-40976-POC