Skip to main content
← All vulnerabilities
CVE-2026-40563GHSA-35XX-9XRG-GWHF

Apache Atlas: Script injection allows access to unintended data

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Description: Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data Affect Version: This issue affects Apache Atlas: from 0.8 through 2.4.0. For the affect version >= 2.0, vulnerability is only when Atlas is deployed with below non-default configuration. atlas.dsl.executor.traversal=false Mitigation: Users are recommended to upgrade to version 2.5.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.atlas:atlas-repository

    From 0.8 · through 2.4.0

  • org.apache.atlas:apache-atlasMaven

    From 0.8 · fixed in 2.5.0

References 1

lists.apache.org