Skip to main content
← All vulnerabilities
CVE-2026-36214

osTicket versions from 1.10 up to 1.17.7 and from 1.18.0 up to 1.18.3 are vulnerable to a stored XSS due to a vulnerable Bootstrap Tooltip c

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.17.8, 1.18.4
1 proof of concept on GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

osTicket versions from 1.10 up to 1.17.7 and from 1.18.0 up to 1.18.3 are vulnerable to a stored XSS due to a vulnerable Bootstrap Tooltip component and insufficient HTML sanitization, allowing remote attackers to execute arbitrary JavaScript in Agent or Admin sessions.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • osTicket osTicket

    From 1.10.0 · fixed in 1.17.8; From 1.18.0 · fixed in 1.18.4

References 6

osticket.com

enhancesoft.com

GitHub · WesWrench/CVE-2026-36214

GitHub · osTicket/osTicket